Nuvi 200 loses satellite Log Out | Topics | Search
Moderators | Edit Profile | SHARC Home

GPS Obsession/Ham Radio Forum » Garmin Forum » Garmin Nuvi Series » Garmin Nuvi User Problems » Nuvi 2xx Series Problems » Nuvi 200 loses satellite « Previous Next »

  Thread Last Poster Posts Pages Last Post
  Start New Thread        

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Tusker (Unregistered Guest)
Posted From: 76.97.167.126
Posted on Wednesday, November 25, 2009 - 03:33 pm:   

Hi,

I have a nuvi 200, which has the latest firmware (5.00), and I have also updated the GPS M chipset to version 2.90.

When I do a master reset, it can find the satellites eventually, and show full reception (all green bars), but after some time, it will show "Poor Satellite Reception" and go back to zero bars. (Not even the first red bar is shown).

Any ideas on how to resolve this one? The Nuvi 200 doesn't have an external antenna, so should not be affected by the external vs internal antenna problem.

Cheers,

Tusker
Top of pagePrevious messageNext messageBottom of page Link to this message

Sharcnetusa
Username: Sharcnetusa

Registered: 12-2008
Posted on Wednesday, November 25, 2009 - 03:45 pm:   

Hi Tusker,

Yes, while it is true that the Nuvi 200 does not have an external antenna jack, it does have the same component that has failed in the Nuvi 3xx & 6xx series and it's right at the antenna input (internal or external antenna).

While I have never had to service a Nuvi 200 for satellite reception issues, it wouldn't surprise me that this part can fail too. It's possible that there may be a problem with the GPS receiver chip and its associated circuitry but I'd try replacing the .41 cent part 1st. It's the easiest & cheapeast thing to try.
Top of pagePrevious messageNext messageBottom of page Link to this message

Tusker (Unregistered Guest)
Posted From: 216.203.24.51
Posted on Monday, November 30, 2009 - 10:16 am:   

Hi,

Thanks so much for that, it was as I suspected (same part, but no jack).

Is it the RF switch, or the "current sensing circuitry" that needs to be replaced?

Cheers,

Tusker
Top of pagePrevious messageNext messageBottom of page Link to this message

Sharcnetusa
Username: Sharcnetusa

Registered: 12-2008
Posted on Monday, November 30, 2009 - 10:23 am:   

Since there is no external antenna jack, there is no RF switch IC nor current sensing circuitry.
Top of pagePrevious messageNext messageBottom of page Link to this message

Tusker (Unregistered Guest)
Posted From: 216.203.24.51
Posted on Monday, November 30, 2009 - 12:09 pm:   

OK, so what is the .41 cent part that I can try to replace? :-)
Top of pagePrevious messageNext messageBottom of page Link to this message

Mitchell (Unregistered Guest)
Posted From: 66.26.94.105
Posted on Monday, January 04, 2010 - 11:39 am:   

i have a 660 and have a satellite reception issues that i continue to lose the satellite.
Top of pagePrevious messageNext messageBottom of page Link to this message

Sharcnetusa
Username: Sharcnetusa

Registered: 12-2008
Posted on Tuesday, January 05, 2010 - 11:25 am:   

This is an easy problem to fix. I will send you a quote.

Add Your Message Here
Post:
Username: Posting Information:
This is a public posting area. Enter your username and password if you have an account. Otherwise, enter your full name as your username and leave the password blank. Your e-mail address is optional.
Password:
E-mail:
Options: Enable HTML code in message
Automatically activate URLs in message
Action:

Topics | Last Day | Last Week | Tree View | Search | Help/Instructions | Program Credits Administration